BD Performance Issues

Incident Report for BlueDolphin

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 09:56 CET

Monitoring

Workaround is applied. BlueDolphin is healthy. Performances are not as expected.
We are waiting for Azure to resolve the issue with DNS services so that we can roll back our changes.
We will continue to monitor.
Posted Oct 29, 2025 - 20:25 CET

Identified

Starting at approximately 16:00 UTC, Azure began experiencing DNS issues, resulting in the availability degradation of some services.
BlueDophin is dependent on the Azure CDN service which is currently inaccessible.
Posted Oct 29, 2025 - 17:47 CET

Investigating

Dear BlueDolphin user,

Starting at 16:45, a portion of customers experienced an authentication issue. There is an ongoing issue with our cloud provider.
We will keep you posted.
Posted Oct 29, 2025 - 17:14 CET
This incident affected: BlueDolphin FrontEnd Services and BlueDolphin BackEnd Services.